Measure Beta Release Notes

Measure 17.1.4464 was made available for select testers on November 6, 2023

Known Issues:

  • "Automatically Refresh" checkbox in Print Preview no longer applies. Changes to preview must always be refreshed manually.

New Features

  • Implemented "Range Edit" on the Product List and Worksheet (MSR-6257)
  • Users may now refresh all product attributes from RFMS, not just prices (MSR-4117)
  • Advanced add-on calculation methods may now be shared within an organization (MSR-6334)
  • As part of the RFMS export process, the user is now prompted to select which reports to include, adjust their settings, and view a preview (MSR-6316)

Improvements

  • The order of Worksheet lines and line groups now persist into the right side panel's "Products" and "Summary" views (MSR-6260)
  • Added the active sheet name to the application title bar, when a project contains more than one sheet (MSR-6274)
  • A new tree view is available in the Material dialog. Both this tree and the original product tree in the Product Palette present colors as sub-properties Products (MSR-6023)
  • Color column width on upper grid of Products dialog is now persisted (MSR-6251)
  • It is now possible to create a project based on an RFMS Quote, Estimate or Order (MSR-3801)
  • Enhanced the Custom Tile tool to make it easier to create large tile patterns (MSR-5856)
  • Improvements to abort function for Custom tile tool (MSR-5856)
  • Adjusted the way area and perimeter for stairs are presented on the status bar (MSR-5974)
  • Added nine new calculation methods for stairs (MSR-6237)
  • Implemented drag and drop behaviors that allow copying of entire Stacks, along with their add-ons and dimensions (MSR-6276)

  • Added option to hide color chip for Add-ons on Forms (MSR-6285)
  • Added the option to create stacks using Material Areas (MSR-6331)

  • Added “Include dividers” checkbox for Worksheet report (MSR-6261)
  • Worksheet reports now include horizontal rule when “Include line items” is not selected (MSR-6261)
  • The user may now query the store database for city information (MSR-6344)
  • When exporting a PDF that contains large images, the system detects whether the output file will be excessively large and offers to reduce its size through rasterization (MSR-6324)
  • A checkbox was added on Forms to optionally show the Gross Quantity of add-ons (MSR-6284)
  • Object highlighting now works with annotations (MSR-6414)
  • Users may now control the opacity of "Object highlight" color (MSR-6402)
  • Clicking on the add-on icon is now easier (MSR-6384)
  • The shape of an existing highlight can be changed; irregularly shaped clouds can be created (MSR-6388)
  • The most recent cloud-based Terms & Conditions are presented when the "Select T&C from cloud" dialog is accessed (MSR-6370)
  • The Terms and Conditions are identified by their title on the Customer screen (MSR-6369)
  • Added filter to the Palette bar (MSR-6312)
  • Added filter to the Sidebar on right (MSR-6064)
  • Added pinned/unpinned icon to sidebars (MSR-6452)
  • Enhanced sorting on Worksheet to be more intuitive (MSR-5949)
  • Project Checkup now alerts the user when their project contains a manually calculated add-on with a quantity of zero (MSR-6482)
  • Improved performance of print preview (MSR-6488)
  • Users are now able to select multiple wall panels and apply Tile Patterns or Stacks to those panels via dragging and dropping (MSR-6510)
  • Allow entry of negative offset amounts for non-rectangular pattern designs (MSR-6546)
  • The Roll dialog is now modeless (MSR-6412)
  • Rolls are now labeled in the Estimate panel (MSR-6411)

Bug Fixes

  • "Reposition Name/Arrow" updates immediately (MSR-6273)
  • "Allow Random Design" functionality has been corrected for all tile patterns (MSR-6272)
  • Some Worksheet cells were not displaying correctly with "Link Worksheet Cells" feature (MSR-6267)
  • Add-ons in Forms were appearing under wrong products when multiple sheets were selected (MSR-6269)
  • In some instances, drawing scale was not saved after using the Rescale Drawing tool (MSR-6252)
  • Certain operations were causing tile to disappear (MSR-6266)
  • Room names were not well positioned in some cases (MSR-6273)
  • Addressed occasional crashes when opening older projects (MSR-6290)
  • The appearance of the drawing on the print preview no longer gets out of sync with the way it appears on the canvas (MSR-6287)

  • Forms: Edge Add-on pricing filters are now consistent with other types of add-ons (MSR-6070)
  • Elevation Plan can no longer affect quantities on Worksheet report (MSR-6282)
  • In the Room Plan preview, lines around room perimeters, room names, and lay direction arrows is no longer too thick in some cases (MSR-6286)
  • The same product no longer appears lighter or darker when used in a pattern and transparency is enabled (MSR-6295)
  • Lay direction was inaccurate on stairways in some situations (MSR-6319)
  • Worksheet updates correctly when switching among sheets in a project (MSR-6317)
  • Addressed problems with text in 3D viewer (MSR-6318)
  • Addressed bug with quantities when printing Worksheet on projects containing stairways (MSR-6300)

  • Forms were not showing subtotals correctly when service only was stipulated (MSR-6155)
  • Fixed Worksheet cells that did not work with "Link Worksheet Cells" feature (MSR-6302)
  • Hidden columns in Product List were not staying hidden when the application is opened from Windows' File Explorer (MSR-6232)
  • Corrected issues with measuring lines, seams and undo (MSR-6326)
  • Importing products from RFMS template was not listing all products in the template (MSR-6330)
  • When a design in the 3D library contains products imported from RFMS, they no longer become unreferenced when exporting to RFMS (MSR-6278)
  • Lay directions for right and left borders was overriding the main lay direction of stairway (MSR-6323)
  • Product images were not showing in the 3D viewer when they were associated with Plank type products (MSR-6279)
  • Adjusting curves no longer scrambles walls in some cases (MSR-6231)
  • Addressed rare cases of "phantom seams" (MSR-6338)
  • Corrected potential crash when navigating Product List (MSR-6353)
  • Counter Nodes are no longer counted as rooms on the Sheet List (MSR-6367)
  • Corrected overlapping text in Forms (MSR-6372)
  • The user material area labels (#1, #2,...) were not well-positioned when the material areas are on a room flap (MSR-6343)

  • Fixed several minor issues with Annotation features (MSR-6362)
  • Deleting a product imported from RFMS and re-importing is now allowed (MSR-6332)
  • Addressed bug where copying and pasting rooms could change Add-on quantities (MSR-6328)
  • 3D text labels no longer appear in the Room Explorer unless the 3D view is shown (MSR-6368)

  • Corrected miscellaneous issues with flaps and material areas (MSR-6343)
  • Corrected issues with user-defined material areas and edge products (MSR-6349)

  • When shared transitions are placed on circular rooms, the system now recognizes that the transition should be shared (MSR-6399)

  • The Cut Sequence button now works correctly if the user selected cuts from the Cut Sequence tree instead of from the canvas (MSR-6333)

  • When logging out, the Save confirmation dialog was presented twice (MSR-6390)
  • Stairs in expanded view with no risers no longer creates a Worksheet error (MSR-6407)
  • Prevented flicker when resizing the main window and the Generate Quotes window (MSR-6379)
  • Very long Terms and Conditions no longer flow off the page in Forms (MSR-6383)
  • Stairways with borders were not allocated if saved immediately (MSR-6357)
  • Rotating a stairway with border resulted in middle material being too wide (MSR-6358)
  • Worksheet and Forms totals could become out of sync (MSR-6322)
  • Jobs generated by older builds are no longer automatically reallocated (MSR-6427)
  • Prevent crashing after importing blueprint and leaving the system idle for an extended period (MSR-6432)
  • Corrected display issues when product images are applied along with border (MSR-6354)

  • The <SheetName> tag in Generate Forms was not displaying the correct sheet name when the project contained Sheet Add-ons (MSR-6210)
  • Prevented crash while adjusting image quality during PDF import (MSR-6375)
  • System no longer crashes when dimension size is set to zero (MSR-6469)
  • Certain patterns when used in the 3D Library no longer crash the system (MSR-6468)
  • Prevented crash with Paint Room tool (MSR-6454)
  • When moving an edge of a user-defined material area, the selections were lost after the move is complete (MSR-6238)
  • When selecting an edge, the screen was not being refreshed (MSR-6238)
  • The color chips in the Product tree are now the correct size when product images are in use (MSR-6356)
  • Prevented stack- and wall-related operations on the edges of user-defined material areas (MSR-6410)
  • Purchase order in Forms was not grouped by vendors (MSR-5930)
  • Page margins in the Print dialog were not sticking when using Metric (MSR-6069)
  • Enhanced sorting on Worksheet to be more intuitive (MSR-5949)
  • Stairs were creating a check up error under certain circumstances that could not be fixed (MSR-6492)
  • NW button on Keypad was mislabeled (MSR-6487)
  • Terms and Conditions now retain their original formatting from RFMS Online Services when they are imported (MSR-6371)
  • Measure was not calculating correct waste percentage with odd shape tile patterns (MSR-6339)
  • White outline around text is preserved when printing or exporting to PDF (MSR-6523)
  • When changing the pattern start to Center Tile or Center Grout, reallocation was not correct (MSR-6475)
  • Border was not maintaining correct width (MSR-6525)
  • Some walls on the elevation plan were missing material (MSR-6389)
  • Zoom level of Estimate panel is now retained when moving cuts (MSR-6440)
  • Addressed issues with displaying seams on stairs (MSR-6496)
  • Corrected unexpected cut movement (MSR-6544)

Measure 17.1.4359 was made available for all testers on March 1, 2023

Bug Fix

  • Addressed potential crash when opening existing projects (MSR-6290)

Measure 17.1.4358 was made available for all testers on February 17, 2023

New Features

  • Individual rooms are now allowed to have multiple names (MSR-6157)

     
  • Default "Room Name Position" and "Arrow Position" may now be set in the Options dialog (MSR-4620)
    • Set default positions for room names and lay direction arrows by going to Measure Options > Display > Room Name:
      mceclip0.png

 

Improvements

  • When attempting to delete a product that is in use, the system now shows the user the rooms where the product is assigned (MSR-6222)
  • The current explorer panel view now persists when navigating to different ribbon bar tabs (MSR-5946)
  • Project Check-up now detects instances where the user employs products sold by EA with incompatible Add-On calculation methods (MSR-6163)
  • Made Highlight and Leader Line selection behavior more intuitive (MSR-6211)
  • Add-On window size and position now persist between sessions (MSR-6212)
  • When navigating away from the Seams tab, the right side panel now reverts to the view it had before the Seams tab was activated (MSR-6233)
  • Room handles (vertex, edge and rotator) are only displayed in contexts where they are usable (MSR-6200)

Bug Fixes

  • The Print Option "Hide all counter nodes" no longer hides leaders and highlights (MSR-6214)
  • Corrected a cosmetic issue with patterns that have a 1/3 drop (MSR-6188)
  • Leader lines with certain print options were causing reports to be blank (MSR-6221)
  • Various operations that were no longer available in the 3D editor are available again (MSR-6169)
  • Textures in 3D viewer no longer disappear after taking a snapshot (MSR-6202)
  • Cuts within rooms that have been sent to back/front now display correctly (MSR-6191)
  • Wall flaps are now correctly placed under their parent rooms on Forms (MSR-6160)
  • Addressed issue with Add-ons assigned to stairway landings (MSR-6197)
  • Fixed quantification issue that could occur with trapezoidal tiles in some situations (MSR-6207)
  • Transition option "Create Punch-Out" was not removing material from the transition in some cases (MSR-6182)
  • Pattern lines on stairs are no longer visible when pattern is removed from the product (MSR-6196)
  • Text Box leader lines now work correctly when Text Box is rotated (MSR-6065)
  • Notes can no longer overlap each other on Checklist report (MSR-6229)
  • "Highlight Object Under Mouse" feature is no longer unresponsive while panning/zooming on projects with imported blueprints (MSR-6135)
  • A number of issues with rotation using the rotator handle have been corrected (MSR-6235)
  • User waste added via the Worksheet now correctly updates the cut view in the Estimate panel (MSR-6224)
  • Terms and Conditions field in Customer Information dialog no longer contains code snippets in projects that were created in Measure Mobile (MSR-4423)
  • Copying and pasting rooms no longer erroneously adds product in some circumstances (MSR-5993)
  • "Risers Exist" option now correctly affects steps when the "Allocate Separately" feature is used (MSR-6220)
  • Various improvements to performance when working with larger projects (MSR-6255)

 


Measure 17.1.4335 was made available for all testers on November 23, 2022

New Features

  • Added Highlight tool (MSR-3682)
    • Click the Highlight icon in the Annotation section of the Ribbon Bar. In the window that appears, enter the settings for the Highlight you want to create. Alternatively, you may choose from a selection of saved Highlights. Click the "Draw Highlight" button to begin drawing.

       
    • Save a custom Highlight to your personal library by defining its settings, entering a label for it, and clicking the green plus icon. 

       
    • Share saved Highlights with others in your organization via the RFMS Cloud. Select a saved Highlight from your personal library and click Share to upload it to the cloud. Select a Highlight from the "Company Designs" library and click "Import" to add it to your personal library.

       
    • Next to the Highlight icon on the ribbon bar is a checkbox labeled "Highlights Selectable". When it is enabled, it allows users to select, move, and resize existing Highlights. When it is disabled, Highlights on the canvas become non-interactable. This prevents users from accidentally moving or editing Highlights while attempting to select and manipulate rooms on the drawing. Note: This checkbox is enabled automatically while the Highlight dialog is active. 
  • Added Leader Line tool (MSR-5917)
      • The process for creating Leader Lines is similar to that of drawing Highlights. The comments and videos above apply in principle to this tool.
  • An annotation legend is now available on applicable plan and seam reports, along with options for positioning and controlling the font size. The text that appears in the legend is based on Label text entered by the user for each annotation. (MSR-6055)
    mceclip1.png

  • Added 3D Snapshot feature (MSR-6022)
    • From the 3D Viewer, click "Manage Snapshots". Click the green plus button to take a new Snapshot or select an existing Snapshot and click the red X to delete it.
      mceclip2.png

    • Include Snapshots in printouts by enabling the 3D Snapshots report from the Print screen.
      mceclip3.png

  • It is now possible to add notes to a 3D printout (MSR-3512)

 

  • Added the ability to link Worksheet cells to Text Boxes, allowing Worksheet data to be displayed on the drawing. Any data displayed using this feature updates dynamically as changes are made to the drawing. (MSR-5995)

     
    • While editing the contents of a Text Box, click the "Link Worksheet Cells" button. Choose any cell and click the "Select" button. A tag will appear at the location of the text cursor. Additional text can be included before or after the tag, and multiple tags may be employed in a single text box.

  • Added a tool that allows Room Names and Lay Direction Arrows to be positioned anywhere within their respective rooms (MSR-6007)
    mceclip4.png
    • When this tool is activated, room names and lay direction arrows can be clicked and dragged to any location within the area of the room they belong to.

  • Products that are part of Bundles in RFMS may now be added to Measure (MSR-3518)
    • After a product is imported from RFMS, select it on the Product List. If it has an associated product bundle in RFMS, a button labeled "Get Bundle" will appear at the bottom of the screen.
       
  • A new quick-rotation handle has been added to all rotatable objects (MSR-6037)
     
  • A new To Do List icon displays the To Do List from Measure Mobile, with the ability to drag products from this list onto rooms in the drawing area. It can be accessed under the Tools tab of the Ribbon Bar. (MSR-5985)

  • Added option for displaying detailed tooltip information about drawing elements (MSR-4873)
    mceclip5.png
    • Enable this feature by going to Measure Options > Drawing > Tooltips and enabling the "Drawing Area" checkbox. 

Improvements

  • When moving cuts on a roll, the system shows a continuous preview of the result (MSR-6074)
  • The text in textboxes may now be rotated (MSR-6036)
  • When importing customers from RFMS, users may now optionally choose to import only the Sold To or only the Ship To data (MSR-5734)
  • The "Favorites" tab in the Select Product dialog now sorts products alphabetically (MSR-5796)
  • Eliminated duplicate dimension labels that could result in room measurements overlapping and becoming illegible (MSR-5834)
  • Improved formatting of Worksheet in non-English languages (MSR-6148)
  • The Cut Increment is imported with products from RFMS (MSR-5903)
  • Reenabled full pattern start options for stairs (MSR-5831)
  • The user is no longer repeatedly prompted to propagate the Taxable flag (MSR-5921)
  • The Measuring Line tool now interacts with t- and length seams (MSR-3910)
  • The Measuring Line tool now interacts with material area boundaries (MSR-4927)
  • Measuring Line endpoints can now be dragged (MSR-4118)
  • Project Checkup now detects instances where estimating width is greater than description width (MSR-5929)
  • Product List flags pre-existing situations in which the Estimating Width is larger than Description Width (MSR-5789)
  • When rooms are deleted, measuring lines are detached, not deleted (MSR-5951)
  • The PDF Import option "Place images on separate sheets" is now sticky (MSR-5997)
  • Private Notes from Measure Mobile are now accessible in Measure Desktop (MSR-5960)
  • Adjusting stair widths when landings are involved now produces more intuitive results (MSR-5977)
  • Brought transitions forward in z-order for purposes of legibility (MSR-5869)
  • Stair dimensions and cut names are now displayed on Room and Seam plans when their respective options are enabled (MSR-5978)
  • Textboxes are always placed at the top of the z-order (MSR-6081)
  • To address performance issues when there are many projects in the cloud, the system now reads in a fixed number with the option to read in more (MSR-6060)
  • Introduced a date range control to the "Open from Cloud" dialog (MSR-6096)
  • Saving a backup to the Cloud should no longer causes the application to briefly become unresponsive (MSR-6151)

Bug Fixes

  • Forms organized by sheet were improperly grouped in some cases (MSR-6122)
  • Deleting user-defined material areas no longer results in the system hanging (MSR-6142)
  • Tile displayed incorrectly in some instances (MSR-6009)
  • Accessing Terms and Conditions was crashing the program under certain circumstances (MSR-6159)
  • Prevented crash of Customer dialog in some cases (MSR-6159)
  • Placing T-Seam on a measuring line caused the system to crash (MSR-5882)
  • Add-ons were incorrectly calculated on stairs in some cases (MSR-5881)
  • Color on display of stairs on roll was sometimes incorrect (MSR-5884)
  • Worksheet correctly refreshes in some instances when changes are made to the Option dialog (MSR-5935)
  • Addressed various issues when transferring tile designs from Measure Desktop to Measure Mobile (MCM-1810)
  • Disto was not rounding up (MSR-5920)
  • Undo was causing the application to hang (MSR-5958)
  • Phantom room names were displayed after room copy and paste operation (MSR-5872)
  • Adding a transition to a room was changing the direction of border material (MSR-5816)
  • Perimeter add-on material was shifting when a room was moved (MSR-5938)
  • Corrected cosmetic issues with Stairway editor - Notes and Photos (MSR-5966)
  • When pattern match is in use, moving the base room did not force allocation (MSR-5912)
  • Hole tool no longer removes material from walls if they are hidden (MSR-5876)
  • Photos attached to Stairs in MM are no longer lost (MSR-5793)
  • Subtotals for hidden Add-Ons is now folded into the subtotal for their parent product (MSR-5892)
  • Cropped Blueprints areas were moving after saving (MSR-5873)
  • Add-ons for stairs was not changing when using palette to select product (MSR-5857)
  • Corrected add-on issues with material areas (MSR-5889)
  • It is now possible to copy and merge sheets with phases from the Sheets dialog (MSR-5678)
  • Prevented extraneous Project Check-up errors in some circumstances (MSR-5900)
  • Non-rectangular products transferred between Measure Desktop and Measure Mobile are now available for non-rectangular tile patterns (MSR-5941)
  • Rectangular stairs were not allocating according to the Max T-Seam parameter (MSR-5893)
  • Attempting to change the angle of a wall using the keypad was causing a crash when the resultant shape was self-crossing (MSR-6011)
  • Sorting forms by gross quantity now places negative numbers first (MSR-5916)
  • Measure Desktop was locking up if more than 24 days had passed since the last re-boot of the host computer (MSR-6012)
  • Color chips for non-rectangular product colors now reflect the product shape (MSR-5940)
  • Hex tiles created using Quick Tile caused errors in the Products dialog (MSR-6028)
  • The Auto-Save dialog no longer gets lost when tabbing back to Measure from another program (MSR-6035)
  • Closing the Add-On dialog was sometimes causing Measure to lose focus (MSR-6033)
  • Tile editor was not handling curved tile shapes correctly (MSR-5934)
  • Measure was renaming room names in rare cases when copied from one sheet to another (MSR-5915)
  • The Elevation report no longer crashes due to changes to the report legend (MSR-6055)
  • Measure Desktop no longer crashes when opened from NHMS (MSR-6044)
  • The Join Material Areas tool no longer inflates the quantity of add-ons (MSR-6078)
  • Marking products as taxable was changing colors for all products (MSR-6123)
  • Grout lines were not displaying correctly in some cases (MSR-6099)
  • Sheet Add-on quantity no longer changes based on Stairway view status (MSR-6119)
  • Expanded view on Stairs with no risers no longer triggers project checkup (MSR-6100)

 

Measure 17.1.4224 was made available for all testers on August 15, 2022

Bug Fixes

  • Placing a t-seam on a Measuring Line no longer produces an error (MSR-5882)
  • Measurements from a Disto now round up when the associated setting is enabled (MSR-5920)
  • Phantom room names no longer appear on the canvas after performing certain operations (MSR-5872)
  • Corrected cosmetic issues with the Stairway Editor > Notes and Photos tab (MSR-5966)
  • Saving a project containing cropped blueprints can no longer cause the blueprints to shift position (MSR-5873)
  • The Add-On calculation method "Copy Floor Gross Quantity" no longer erroneously triggers Project Checkup under certain circumstances (MSR-5900)
  • Material quantities on stairs can no longer change depending on whether the stairway is viewed in Expanded or Standard mode (MSR-5881)

 


Measure 17.1.4222 was made available for all testers on April 22, 2022

Improvements

  • When "Taxable" is enabled for a product on the Product List, the system offers to enable it for other items (MSR-5801)
  • Stairway setting "Expanded view" is now sticky (MSR-5815)
  • An option has been added to the 3D section of the Ribbon Bar to show seams in the 3D rendering (MSR-5698)
  • More accurate display and calculation of grout in complex tile patterns (MSR-5700)
  • The "New Project" option has been restored to the Welcome dialog (MSR-5752)
  • The creation of square/rectangle rooms using two lines only occurs if the lines are at a right angle relative to each other and the screen (MSR-5837)

Bug Fixes

  • Addressed numerous crashing and freezing issues (MSR-5847, MSR-5833, MSR-5854, MSR-5784, MSR-5846, MSR-5819, MSR-5864, MSR-5779, MSR-5788)
  • Rooms can no longer be offset from imported image when exporting to PDF (MSR-5671)
  • Resolved issues related to backing up to the Cloud (MSR-5769)
  • Total Tax now shows correctly under Grand Total in Forms screen (MSR-5693)
  • Fixed many cosmetic issues that could occur when Dark Mode is enabled (MSR-5771, MSR-5764, MSR-5759, MSR-5763)
  • Fixed quantification issue when Service or Miscellaneous items are assigned to floors with coving (MSR-5814)
  • Hole tools can no longer erroneously create rooms in some circumstances (MSR-5818)
  • The width of Sidebars now persists when they are resized in the unpinned state (MSR-5778)
  • Sidebar widths are properly restored when DPI setting is changed (MSR-5778)
  • PDF export no longer crops photos in some circumstances (MSR-5756)
  • Expanding or contracting of stairs can no longer affect locked cuts (MSR-5841)
  • Perimeter Add-on quantity on stairs no longer changes between expanded/contracted view (MSR-5836)
  • Rooms can no longer be flagged as self-intersecting when they are not (MSR-5742)
  • In some cases involving multiple borders, the correct material areas were not generated (MSR-5742)
  • Corrected icon size in Welcome dialog (MSR-5752)
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.

Powered by Zendesk